PyPI/openc3 CVE-2026-42086: medium 4.6, EPSS 0.20%
OpenC3 COSMOS is Vulnerable to Self-XSS Through the Command Sender
Action: Upgrade openc3 to 7.0.0 or later.
pip install openc3==7.0.0Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 7.0.0 | - |
Fixed versions
| 7.0.0 |
Sources
- osv: GHSA-ffq5-qpvf-xq7x#PyPI/openc3
- https://github.com/OpenC3/cosmos/security/advisories/GHSA-ffq5-qpvf-xq7x
- https://nvd.nist.gov/vuln/detail/CVE-2026-42086
- https://github.com/OpenC3/cosmos
- https://github.com/pypa/advisory-database/tree/main/vulns/openc3/PYSEC-2026-105.yaml
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/openc3/CVE-2026-42086.yml
CVE-2026-42086 · published · modified · JSON