PyPI/vncauthproxy CVE-2022-36436: critical 9.8, EPSS 2.07%
VNCAuthProxy authentication bypass vulnerability
Action: Upgrade vncauthproxy to 1.2.0 or later.
pip install vncauthproxy==1.2.0Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 1.2.0 | - |
Fixed versions
| 1.2.0 |
Sources
- osv: GHSA-237r-mx84-7x8c
- https://nvd.nist.gov/vuln/detail/CVE-2022-36436
- https://github.com/osuosl/twisted_vncauthproxy/commit/edc149af29242178091b2d6fcd42c3ef0851644b
- https://cert.grnet.gr/en/blog/cve-2022-36436-twisted-vnc-authentication-proxy-authentication-bypass
- https://github.com/osuosl/twisted_vncauthproxy
- https://github.com/osuosl/twisted_vncauthproxy/tree/release/1.1.1
- https://github.com/pypa/advisory-database/tree/main/vulns/vncauthproxy/PYSEC-2022-267.yaml
- https://pypi.org/project/VNCAuthProxy
CVE-2022-36436 · published · modified · JSON