PyPI/tensorflow-gpu CVE-2022-23591: high 7.5, EPSS 0.80%
Stack overflow in TensorFlow
Action: Upgrade tensorflow-gpu to 2.5.3 or later.
pip install tensorflow-gpu==2.5.3pip install tensorflow-gpu==2.6.3pip install tensorflow-gpu==2.7.1Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 2.5.3 | - |
| 2.6.0 | 2.6.3 | - |
| 2.7.0 | 2.7.1 | - |
Fixed versions
| 2.5.3 | 2.6.3 | 2.7.1 |
Sources
- osv: GHSA-247x-2f9f-5wp7#PyPI/tensorflow-gpu
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-247x-2f9f-5wp7
- https://nvd.nist.gov/vuln/detail/CVE-2022-23591
- https://github.com/tensorflow/tensorflow/commit/448a16182065bd08a202d9057dd8ca541e67996c
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2022-100.yaml
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2022-155.yaml
- https://github.com/tensorflow/tensorflow
CVE-2022-23591 · published · modified · JSON