PyPI/gitpython CVE-2026-78676: critical 9.8, EPSS 0.78%
GitPython: Dormant multi-line git-config values are corrupted into live injected directives (e.g. core.hooksPath) on any unrelated GitConfigParser write, enabling RCE
Action: Upgrade gitpython to 3.1.59 or later.
pip install gitpython==3.1.59Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 3.1.59 | - |
Fixed versions
| 3.1.59 |
Sources
- osv: GHSA-284h-m62q-gf8w
- https://github.com/gitpython-developers/GitPython/security/advisories/GHSA-284h-m62q-gf8w
- https://nvd.nist.gov/vuln/detail/CVE-2026-78676
- https://github.com/gitpython-developers/GitPython
- https://github.com/pypa/advisory-database/tree/main/vulns/gitpython/PYSEC-2026-3786.yaml
- https://www.vulncheck.com/advisories/gitpython-before-remote-code-execution-via-config-injection
CVE-2026-78676 · published · modified · JSON