PyPI/django CVE-2014-0481: high 7.5, EPSS 2.47%
Django denial of service via file upload naming
Action: Upgrade django to 1.4.14 or later.
pip install django==1.4.14pip install django==1.5.9pip install django==1.6.6Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 1.4.14 | - |
| 1.5 | 1.5.9 | - |
| 1.6 | 1.6.6 | - |
Fixed versions
| 1.4.14 | 1.5.9 | 1.6.6 |
Sources
- osv: GHSA-296w-6qhq-gf92
- https://nvd.nist.gov/vuln/detail/CVE-2014-0481
- https://github.com/django/django/commit/26cd48e166ac4d84317c8ee6d63ac52a87e8da99
- https://github.com/django/django/commit/30042d475bf084c6723c6217a21598d9247a9c41
- https://github.com/django/django/commit/dd0c3f4ee1a30c1a1e6055061c6ba6e58c6b54d1
- https://github.com/django/django
- https://github.com/pypa/advisory-database/tree/main/vulns/django/PYSEC-2014-5.yaml
- https://www.djangoproject.com/weblog/2014/aug/20/security
- http://lists.opensuse.org/opensuse-updates/2014-09/msg00023.html
- http://www.debian.org/security/2014/dsa-3010
CVE-2014-0481 · published · modified · JSON