tocsin

PyPI/litestar CVE-2026-25478: high 7.4, EPSS 0.45%

Litestar's CORS origin allowlist has a bypass due to unescaped regex metacharacters in allowed origins

Action: Upgrade litestar to 2.20.0 or later.

pip install litestar==2.20.0

Affected

introducedfixedlast affected
2.19.02.20.0-

Fixed versions

2.20.0

Sources

CVE-2026-25478 · published · modified · JSON