PyPI/soupsieve CVE-2026-49476: high 7.5, EPSS 0.64%
Soup Sieve has Memory Exhaustion via Large Comma-Separated Selector Lists
Action: Upgrade soupsieve to 2.8.4 or later.
pip install soupsieve==2.8.4Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 2.8.4 | - |
Fixed versions
| 2.8.4 |
Sources
- osv: GHSA-2wc2-fm75-p42x
- https://github.com/facelessuser/soupsieve/security/advisories/GHSA-2wc2-fm75-p42x
- https://github.com/facelessuser/soupsieve
CVE-2026-49476 · published · modified · JSON