PyPI/frappe CVE-2025-30212: high 7.5, EPSS 0.44%
Frappe has possibility of SQL injection due to improper validations
Action: Upgrade frappe to 14.89.0 or later.
pip install frappe==14.89.0pip install frappe==15.51.0Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 14.89.0 | - |
| 15.0.0 | 15.51.0 | - |
Fixed versions
| 14.89.0 | 15.51.0 |
Sources
- osv: GHSA-3hj6-r5c9-q8f3
- nvd: CVE-2025-30212
- https://github.com/frappe/frappe/security/advisories/GHSA-3hj6-r5c9-q8f3
- https://github.com/frappe/frappe/commit/27f13437db161a173137d91cd07d0f9287d7c556
- https://github.com/frappe/frappe/commit/2ebd88520ecfa9bb7d3392b7de8c8f94a86ec05c
- https://github.com/frappe/frappe
CVE-2025-30212 · published · modified · JSON