tocsin

PyPI/vyper CVE-2023-31146: high 7.5, EPSS 1.24%

Vyper vulnerable to OOB DynArray access when array is on both LHS and RHS of an assignment

Action: Upgrade vyper to 0.3.8 or later.

pip install vyper==0.3.8

Affected

introducedfixedlast affected
00.3.8-

Fixed versions

0.3.8

Sources

CVE-2023-31146 · published · modified · JSON