PyPI/capstone CVE-2017-6952: high 8.8, EPSS 1.26%
Capstone Integer overflow
Action: Upgrade capstone to 3.0.5rc2 or later.
pip install capstone==3.0.5rc2Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 3.0.5rc2 | - |
Fixed versions
| 3.0.5rc2 |
Sources
- osv: GHSA-3v99-hpv7-9hh9
- https://nvd.nist.gov/vuln/detail/CVE-2017-6952
- https://github.com/aquynh/capstone/commit/6fe86eef621b9849f51a5e1e5d73258a93440403
- https://github.com/capstone-engine/capstone
- https://github.com/pypa/advisory-database/tree/main/vulns/capstone/PYSEC-2017-113.yaml
CVE-2017-6952 · published · modified · JSON