PyPI/vyper CVE-2024-32647: medium 5.3, EPSS 0.46%
vyper performs double eval of raw_args in create_from_blueprint
Action: Upgrade vyper to 0.4.0 or later.
pip install vyper==0.4.0Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 0.4.0 | - |
Fixed versions
| 0.4.0 |
Sources
- osv: GHSA-3whq-64q2-qfj6
- https://github.com/vyperlang/vyper/security/advisories/GHSA-3whq-64q2-qfj6
- https://nvd.nist.gov/vuln/detail/CVE-2024-32647
- https://github.com/pypa/advisory-database/tree/main/vulns/vyper/PYSEC-2024-208.yaml
- https://github.com/vyperlang/vyper
- https://github.com/vyperlang/vyper/blob/cedf7087e68e67c7bfbd47ae95dcb16b81ad2e02/vyper/builtins/functions.py#L1847
CVE-2024-32647 · published · modified · JSON