tocsin

PyPI/pyspark CVE-2022-31777: medium 5.4, EPSS 1.64%

Apache Spark vulnerable to Log Injection

Action: Upgrade pyspark to 3.2.2 (3.2.x) or 3.3.1 (3.3.x) or later.

pip install pyspark==3.2.2
pip install pyspark==3.3.1

Affected

introducedfixedlast affected
03.2.2-
3.3.03.3.1-

Fixed versions

3.2.23.3.1

Sources

CVE-2022-31777 · published · modified · JSON