PyPI/simpleeval CVE-2026-32640: critical 9.8, EPSS 0.54%
SimpleEval: Objects (including modules) can leak dangerous modules through to direct access inside the sandbox
Action: Upgrade simpleeval to 1.0.5 or later.
pip install simpleeval==1.0.5Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 1.0.5 | - |
Fixed versions
| 1.0.5 |
Sources
- osv: GHSA-44vg-5wv2-h2hg
- https://github.com/danthedeckie/simpleeval/security/advisories/GHSA-44vg-5wv2-h2hg
- https://nvd.nist.gov/vuln/detail/CVE-2026-32640
- https://github.com/danthedeckie/simpleeval
- https://github.com/danthedeckie/simpleeval/releases/tag/1.0.5
- https://github.com/pypa/advisory-database/tree/main/vulns/simpleeval/PYSEC-2026-132.yaml
- https://lists.debian.org/debian-lts-announce/2026/04/msg00023.html
CVE-2026-32640 · published · modified · JSON