PyPI/tensorflow CVE-2021-29616: low 2.5, EPSS 0.21%
Null dereference in Grappler's `TrySimplify`
Action: Upgrade tensorflow to 2.1.4 or later.
pip install tensorflow==2.1.4pip install tensorflow==2.2.3pip install tensorflow==2.3.3pip install tensorflow==2.4.2Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 2.1.4 | - |
| 2.2.0 | 2.2.3 | - |
| 2.3.0 | 2.3.3 | - |
| 2.4.0 | 2.4.2 | - |
Fixed versions
| 2.1.4 | 2.2.3 | 2.3.3 | 2.4.2 |
Sources
- osv: GHSA-4hvv-7x94-7vq8
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-4hvv-7x94-7vq8
- https://nvd.nist.gov/vuln/detail/CVE-2021-29616
- https://github.com/tensorflow/tensorflow/commit/e6340f0665d53716ef3197ada88936c2a5f7a2d3
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2021-544.yaml
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2021-742.yaml
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2021-253.yaml
- https://github.com/tensorflow/tensorflow
CVE-2021-29616 · published · modified · JSON