PyPI/vyper CVE-2022-29255: high 7.5, EPSS 1.35%
Multiple evaluation of contract address in call in vyper
Action: Upgrade vyper to 0.3.4 or later.
pip install vyper==0.3.4Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 0.3.4 | - |
Fixed versions
| 0.3.4 |
Sources
- osv: GHSA-4v9q-cgpw-cf38
- https://github.com/vyperlang/vyper/security/advisories/GHSA-4v9q-cgpw-cf38
- https://nvd.nist.gov/vuln/detail/CVE-2022-29255
- https://github.com/vyperlang/vyper/commit/6b4d8ff185de071252feaa1c319712b2d6577f8d
- https://github.com/pypa/advisory-database/tree/main/vulns/vyper/PYSEC-2022-43053.yaml
- https://github.com/vyperlang/vyper
CVE-2022-29255 · published · modified · JSON