PyPI/global-workqueue CVE-2022-34558: critical 9.8, EPSS 1.30%
WMAgent arbitrary code execution via a crafted dbs-client package
Action: Upgrade global-workqueue to 2.0.4 or later.
pip install global-workqueue==2.0.4Affected
| introduced | fixed | last affected |
|---|---|---|
| 1.4.1rc5 | 2.0.4 | - |
Fixed versions
| 2.0.4 |
Sources
- osv: GHSA-4vq7-8699-4xgc#PyPI/global-workqueue
- https://nvd.nist.gov/vuln/detail/CVE-2022-34558
- https://github.com/dmwm/WMCore/issues/11188
- https://github.com/dmwm/WMCore
- https://github.com/pypa/advisory-database/tree/main/vulns/global-workqueue/PYSEC-2022-43136.yaml
- https://github.com/pypa/advisory-database/tree/main/vulns/reqmon/PYSEC-2022-43163.yaml
- https://github.com/pypa/advisory-database/tree/main/vulns/wmagent/PYSEC-2022-43174.yaml
CVE-2022-34558 · published · modified · JSON