PyPI/vyper CVE-2025-27105: critical 9.1, EPSS 0.57%
AugAssign evaluation order causing OOB write within the object in Vyper
Action: Upgrade vyper to 0.4.1 or later.
pip install vyper==0.4.1Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 0.4.1 | - |
Fixed versions
| 0.4.1 |
Sources
- osv: GHSA-4w26-8p97-f4jp
- nvd: CVE-2025-27105
- https://github.com/vyperlang/vyper/security/advisories/GHSA-4w26-8p97-f4jp
- https://github.com/pypa/advisory-database/tree/main/vulns/vyper/PYSEC-2025-31.yaml
- https://github.com/vyperlang/vyper
CVE-2025-27105 · published · modified · JSON