PyPI/django-s3file CVE-2022-24840: critical 9.1, EPSS 2.07%
Path Traversal in django-s3file
Action: Upgrade django-s3file to 5.5.1 or later.
pip install django-s3file==5.5.1Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 5.5.1 | - |
Fixed versions
| 5.5.1 |
Sources
- osv: GHSA-4w8f-hjm9-xwgf
- https://github.com/codingjoe/django-s3file/security/advisories/GHSA-4w8f-hjm9-xwgf
- https://nvd.nist.gov/vuln/detail/CVE-2022-24840
- https://github.com/codingjoe/django-s3file/commit/68ccd2c621a40eb66fdd6af2be9d5fcc9c373318
- https://github.com/codingjoe/django-s3file
- https://github.com/codingjoe/django-s3file/releases/tag/5.5.1
- https://github.com/pypa/advisory-database/tree/main/vulns/django-s3file/PYSEC-2022-208.yaml
CVE-2022-24840 · published · modified · JSON