tocsin

PyPI/pygments CVE-2026-4539: low 3.3, EPSS 0.16%

Pygments has Regular Expression Denial of Service (ReDoS) due to Inefficient Regex for GUID Matching

Action: Upgrade pygments to 2.20.0 or later.

pip install pygments==2.20.0

Affected

introducedfixedlast affected
02.20.0-

Fixed versions

2.20.0

Sources

CVE-2026-4539 · published · modified · JSON