PyPI/banks CVE-2026-107716: high 7.3, EPSS 0.13%
Banks: Symlink traversal and arbitrary file disclosure/overwrite in DirectoryPromptRegistry
Action: Upgrade banks to 2.5.1 or later.
pip install banks==2.5.1Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 2.5.1 | - |
Fixed versions
| 2.5.1 |
Sources
- osv: GHSA-556j-vv39-8rqv
- nvd: CVE-2026-107716
- https://github.com/masci/banks/security/advisories/GHSA-556j-vv39-8rqv
- https://github.com/masci/banks/pull/79
- https://github.com/masci/banks/commit/23ed13e50b4e217693fa5f9c30943fac8a41582f
- https://github.com/masci/banks
- https://github.com/masci/banks/releases/tag/v2.5.1
CVE-2026-107716 · published · modified · JSON