PyPI/pyftpdlib CVE-2007-6739: high 7.5, EPSS 2.21%
Improper Input Validation in pyftpdlib
Action: Upgrade pyftpdlib to 0.2.0 or later.
pip install pyftpdlib==0.2.0Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 0.2.0 | - |
Fixed versions
| 0.2.0 |
Sources
- osv: GHSA-5f3f-pg2c-cxcv
- https://nvd.nist.gov/vuln/detail/CVE-2007-6739
- https://github.com/giampaolo/pyftpdlib/issues/3
- https://github.com/advisories/GHSA-5f3f-pg2c-cxcv
- https://github.com/giampaolo/pyftpdlib
- https://github.com/pypa/advisory-database/tree/main/vulns/pyftpdlib/PYSEC-2010-23.yaml
- http://code.google.com/p/pyftpdlib/issues/detail?id=3
- http://code.google.com/p/pyftpdlib/source/browse/trunk/HISTORY
- http://code.google.com/p/pyftpdlib/source/detail?r=20
- http://code.google.com/p/pyftpdlib/source/diff?spec=svn20&r=20&format=side&path=/trunk/pyftpdlib/FTPServer.py
CVE-2007-6739 · published · modified · JSON