PyPI/fastmcp CVE-2025-69196: medium 6.5, EPSS 0.38%
FastMCP OAuth Proxy token reuse across MCP servers
Action: Upgrade fastmcp to 2.14.2 or later.
pip install fastmcp==2.14.2Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 2.14.2 | - |
Fixed versions
| 2.14.2 |
Sources
- osv: GHSA-5h2m-4q8j-pqpj
- nvd: CVE-2025-69196
- https://github.com/PrefectHQ/fastmcp/security/advisories/GHSA-5h2m-4q8j-pqpj
- https://github.com/PrefectHQ/fastmcp
CVE-2025-69196 · published · modified · JSON