PyPI/pypdf CVE-2026-49460: low 3.3, EPSS 0.17%
pypdf: Inefficient decoding of FlateDecode PNG predictor streams
Action: Upgrade pypdf to 6.12.2 or later.
pip install pypdf==6.12.2Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 6.12.2 | - |
Fixed versions
| 6.12.2 |
Sources
- osv: GHSA-5hgr-hg42-57jg
- nvd: CVE-2026-49460
- https://github.com/py-pdf/pypdf/security/advisories/GHSA-5hgr-hg42-57jg
- https://github.com/py-pdf/pypdf/pull/3806
- https://github.com/py-pdf/pypdf
- https://github.com/py-pdf/pypdf/releases/tag/6.12.2
CVE-2026-49460 · published · modified · JSON