PyPI/llama-index CVE-2025-6211: medium 6.5, EPSS 0.36%
LlamaIndex vulnerable to data loss through hash collisions in its DocugamiReader class
Action: Upgrade llama-index to 0.12.41 or later.
pip install llama-index==0.12.41Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 0.12.41 | - |
Fixed versions
| 0.12.41 |
Sources
- osv: GHSA-5hq9-5r78-2gjh
- https://nvd.nist.gov/vuln/detail/CVE-2025-6211
- https://github.com/run-llama/llama_index/commit/29b2e07e64ed7d302b1cc058185560b28eaa1352
- https://github.com/run-llama/llama_index
- https://huntr.com/bounties/1a48a011-a3c5-4979-9ffc-9652280bc389
CVE-2025-6211 · published · modified · JSON