PyPI/virtualbmc CVE-2022-44020: medium 5.5, EPSS 0.24%
OpenStack Sushy-Tools and VirtualBMC Improper Preservation of Permissions
Action: Upgrade virtualbmc to 3.0.0 or later.
pip install virtualbmc==3.0.0Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 3.0.0 | - |
Fixed versions
| 3.0.0 |
Sources
- osv: GHSA-5pj3-6fqm-8m7m#PyPI/virtualbmc
- https://nvd.nist.gov/vuln/detail/CVE-2022-44020
- https://github.com/umago/virtualbmc
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/GAD7QJIUWPCKJIGYP7PPHH5DILOEONFE
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/KEQVJF3OQGSDCSQTQQSC54JEGLMSNB4Q
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/QMSUGS4B6EBRHBJMTRXL5RIKJTZTEMJC
- https://review.opendev.org/c/openstack/sushy-tools/+/862625
- https://review.opendev.org/c/openstack/virtualbmc/+/862620
- https://storyboard.openstack.org/#!/story/2010382
CVE-2022-44020 · published · modified · JSON