PyPI/pyopenssl CVE-2026-27459: critical 9.8, EPSS 0.73%
pyOpenSSL DTLS cookie callback buffer overflow
Action: Upgrade pyopenssl to 26.0.0 or later.
pip install pyopenssl==26.0.0Affected
| introduced | fixed | last affected |
|---|---|---|
| 22.0.0 | 26.0.0 | - |
Fixed versions
| 26.0.0 |
Sources
- osv: GHSA-5pwr-322w-8jr4
- nvd: CVE-2026-27459
- https://github.com/pyca/pyopenssl/security/advisories/GHSA-5pwr-322w-8jr4
- https://github.com/pyca/pyopenssl/commit/57f09bb4bb051d3bc2a1abd36e9525313d5cd408
- https://github.com/pyca/pyopenssl
- https://github.com/pyca/pyopenssl/blob/358cbf29c4e364c59930e53a270116249581eaa3/CHANGELOG.rst
CVE-2026-27459 · published · modified · JSON