PyPI/snowflake-connector-python CVE-2024-49750: medium 5.5, EPSS 0.20%
The Snowflake Connector for Python stores sensitive data in logs
Action: Upgrade snowflake-connector-python to 3.12.3 or later.
pip install snowflake-connector-python==3.12.3Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 3.12.3 | - |
Fixed versions
| 3.12.3 |
Sources
- osv: GHSA-5vvg-pvhp-hv2m
- https://github.com/snowflakedb/snowflake-connector-python/security/advisories/GHSA-5vvg-pvhp-hv2m
- https://nvd.nist.gov/vuln/detail/CVE-2024-49750
- https://github.com/snowflakedb/snowflake-connector-python/commit/dbc9284a3c0382c131b971b35e8d6ab93c46f37a
- https://github.com/pypa/advisory-database/tree/main/vulns/snowflake-connector-python/PYSEC-2024-191.yaml
- https://github.com/snowflakedb/snowflake-connector-python
CVE-2024-49750 · published · modified · JSON