PyPI/pymdown-extensions CVE-2026-46338: medium 4.3, EPSS 0.40%
Regression in pymdownx.snippets reintroduces sibling-prefix path traversal bypass despite restrict_base_path
Action: Upgrade pymdown-extensions to 10.21.3 or later.
pip install pymdown-extensions==10.21.3Affected
| introduced | fixed | last affected |
|---|---|---|
| 10.0.1 | 10.21.3 | - |
Fixed versions
| 10.21.3 |
Sources
- osv: GHSA-62q4-447f-wv8h
- https://github.com/facelessuser/pymdown-extensions/security/advisories/GHSA-62q4-447f-wv8h
- https://github.com/facelessuser/pymdown-extensions/pull/2039
- https://github.com/facelessuser/pymdown-extensions
CVE-2026-46338 · published · modified · JSON