PyPI/kedro CVE-2026-35167: high 7.1, EPSS 0.33%
Kedro: Path Traversal in versioned dataset loading via unsanitized version string
Action: Upgrade kedro to 1.3.0 or later.
pip install kedro==1.3.0Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 1.3.0 | - |
Fixed versions
| 1.3.0 |
Sources
- osv: GHSA-6326-w46w-ppjw
- https://github.com/kedro-org/kedro/security/advisories/GHSA-6326-w46w-ppjw
- https://nvd.nist.gov/vuln/detail/CVE-2026-35167
- https://github.com/kedro-org/kedro/pull/5442
- https://github.com/kedro-org/kedro
- https://github.com/pypa/advisory-database/tree/main/vulns/kedro/PYSEC-2026-71.yaml
CVE-2026-35167 · published · modified · JSON