PyPI/ipython CVE-2015-4707: medium 6.1, EPSS 2.27%
Improper Neutralization of Input During Web Page Generation in IPython
Action: Upgrade ipython to 3.2.0 or later.
pip install ipython==3.2.0Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 3.2.0 | - |
Fixed versions
| 3.2.0 |
Sources
- osv: GHSA-66gw-5xpf-gfp5
- https://nvd.nist.gov/vuln/detail/CVE-2015-4707
- https://github.com/ipython/ipython/commit/7222bd53ad089a65fd610fab4626f9d0ab47dfce
- https://github.com/ipython/ipython/commit/c2078a53543ed502efd968649fee1125e0eb549c
- https://bugzilla.redhat.com/show_bug.cgi?id=1235688
- https://github.com/advisories/GHSA-66gw-5xpf-gfp5
- https://github.com/ipython/ipython
- https://github.com/pypa/advisory-database/tree/main/vulns/ipython/PYSEC-2017-46.yaml
- https://ipython.org/ipython-doc/3/whatsnew/version3.html
- https://web.archive.org/web/20200227150022/https://www.securityfocus.com/bid/75328
- http://www.openwall.com/lists/oss-security/2015/06/22/7
CVE-2015-4707 · published · modified · JSON