PyPI/vyper CVE-2024-24559: low 3.7, EPSS 0.26%
Vyper sha3 codegen bug
Action: Upgrade vyper to 0.4.0 or later.
pip install vyper==0.4.0Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 0.4.0 | - |
Fixed versions
| 0.4.0 |
Sources
- osv: GHSA-6845-xw22-ffxv
- https://github.com/vyperlang/vyper/security/advisories/GHSA-6845-xw22-ffxv
- https://nvd.nist.gov/vuln/detail/CVE-2024-24559
- https://github.com/vyperlang/vyper/pull/4063
- https://github.com/vyperlang/vyper/commit/d9f9fdadd81a148cbc68f02dbbbcdc0c92fad652
- https://github.com/pypa/advisory-database/tree/main/vulns/vyper/PYSEC-2024-147.yaml
- https://github.com/vyperlang/vyper
- https://github.com/vyperlang/vyper/blob/c150fc49ee9375a930d177044559b83cb95f7963/vyper/ir/compile_ir.py#L585-L586
CVE-2024-24559 · published · modified · JSON