PyPI/changedetection-io CVE-2026-29039: high 7.5, EPSS 0.50%
changedetection.io vulnerable to XPath - Arbitrary File Read via unparsed-text()
Action: Upgrade changedetection-io to 0.54.4 or later.
pip install changedetection-io==0.54.4Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 0.54.4 | - |
Fixed versions
| 0.54.4 |
Sources
- osv: GHSA-6fmw-82m7-jq6p
- nvd: CVE-2026-29039
- https://github.com/dgtlmoon/changedetection.io/security/advisories/GHSA-6fmw-82m7-jq6p
- https://github.com/dgtlmoon/changedetection.io/commit/417d57e5749441e4be9acc4010369bded805d66f
- https://github.com/dgtlmoon/changedetection.io
- https://github.com/dgtlmoon/changedetection.io/releases/tag/0.54.4
CVE-2026-29039 · published · modified · JSON