PyPI/zenml CVE-2024-9340: high 7.5, EPSS 0.97%
ZenML unauthenticated DoS via Multipart Boundry
Action: Upgrade zenml to 0.68.0 or later.
pip install zenml==0.68.0Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 0.68.0 | - |
Fixed versions
| 0.68.0 |
Sources
- osv: GHSA-6gmf-2369-c76c
- https://nvd.nist.gov/vuln/detail/CVE-2024-9340
- https://github.com/zenml-io/zenml/commit/cba152eb9ca3071c8372b0b91c02d9d3351de48d
- https://github.com/pypa/advisory-database/tree/main/vulns/zenml/PYSEC-2025-57.yaml
- https://github.com/zenml-io/zenml
- https://huntr.com/bounties/c9200654-7dc0-4c1d-8573-ab79a87fb4f6
CVE-2024-9340 · published · modified · JSON