PyPI/keystone CVE-2020-12690: high 8.8, EPSS 1.90%
Insufficient Session Expiration in OpenStack Keystone
Action: Upgrade keystone to 15.0.1 or later.
pip install keystone==15.0.1pip install keystone==16.0.0Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 15.0.1 | - |
| 16.0.0.0rc1 | 16.0.0 | - |
Fixed versions
| 15.0.1 | 16.0.0 |
Sources
- osv: GHSA-6m8p-x4qw-gh5j
- https://nvd.nist.gov/vuln/detail/CVE-2020-12690
- https://bugs.launchpad.net/keystone/+bug/1873290
- https://github.com/advisories/GHSA-6m8p-x4qw-gh5j
- https://github.com/openstack/keystone
- https://github.com/pypa/advisory-database/tree/main/vulns/keystone/PYSEC-2020-54.yaml
- https://lists.apache.org/thread.html/re4ffc55cd2f1b55a26e07c83b3c22c3fe4bae6054d000a57fb48d8c2@%3Ccommits.druid.apache.org%3E
- https://security.openstack.org/ossa/OSSA-2020-005.html
- https://usn.ubuntu.com/4480-1
- https://www.openwall.com/lists/oss-security/2020/05/06/6
- http://www.openwall.com/lists/oss-security/2020/05/07/3
CVE-2020-12690 · published · modified · JSON