PyPI/koji CVE-2018-1002150: critical 9.1, EPSS 1.66%
Koji hub call does not perform correct access checks
Action: Upgrade koji to 1.12.1 or later.
pip install koji==1.15.1pip install koji==1.14.1pip install koji==1.13.1pip install koji==1.12.1Affected
| introduced | fixed | last affected |
|---|---|---|
| 1.15 | 1.15.1 | - |
| 1.14 | 1.14.1 | - |
| 1.13 | 1.13.1 | - |
| 1.12 | 1.12.1 | - |
Fixed versions
| 1.15.1 | 1.14.1 | 1.13.1 | 1.12.1 |
Sources
- osv: GHSA-6mww-xvh7-fq4f
- https://nvd.nist.gov/vuln/detail/CVE-2018-1002150
- https://docs.pagure.org/koji/CVE-2018-1002150
- https://github.com/advisories/GHSA-6mww-xvh7-fq4f
- https://github.com/pypa/advisory-database/tree/main/vulns/koji/PYSEC-2018-86.yaml
- https://pagure.io/koji
- https://pagure.io/koji/c/ab1ade7
- https://pagure.io/koji/issue/850
CVE-2018-1002150 · published · modified · JSON