PyPI/scalyr-agent-2 CVE-2020-24715: critical 9.8, EPSS 0.77%
Scalyr Agent 2 Missing SSL Certificate Validation
Action: Upgrade scalyr-agent-2 to 2.1.10 or later.
pip install scalyr-agent-2==2.1.10Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 2.1.10 | - |
Fixed versions
| 2.1.10 |
Sources
- osv: GHSA-738x-v49g-p6hx
- https://nvd.nist.gov/vuln/detail/CVE-2020-24715
- https://github.com/pypa/advisory-database/tree/main/vulns/scalyr-agent-2/PYSEC-2020-252.yaml
- https://github.com/scalyr/scalyr-agent-2
- https://github.com/scalyr/scalyr-agent-2/blob/v2.1.10/CHANGELOG.md
- https://scalyr-static.s3.amazonaws.com/technical-details/index.html
- https://web.archive.org/web/20211209045826/https://scalyr-static.s3.amazonaws.com/technical-details/index.html
CVE-2020-24715 · published · modified · JSON