PyPI/pyjwt CVE-2026-32597: high 7.5, EPSS 0.27%
PyJWT accepts unknown `crit` header extensions
Action: Upgrade pyjwt to 2.12.0 or later.
pip install pyjwt==2.12.0Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 2.12.0 | - |
Fixed versions
| 2.12.0 |
Sources
- osv: GHSA-752w-5fwx-jx9f
- https://github.com/jpadilla/pyjwt/security/advisories/GHSA-752w-5fwx-jx9f
- https://nvd.nist.gov/vuln/detail/CVE-2026-32597
- https://github.com/jpadilla/pyjwt
- https://github.com/pypa/advisory-database/tree/main/vulns/pyjwt/PYSEC-2026-120.yaml
- https://lists.debian.org/debian-lts-announce/2026/05/msg00008.html
CVE-2026-32597 · published · modified · JSON