tocsin

PyPI/gitpython CVE-2026-44243: high 7.1, EPSS 0.42%

GitPython reference APIs has a path traversal vulnerability that allows arbitrary file write and delete outside the repository

Action: Upgrade gitpython to 3.1.48 or later.

pip install gitpython==3.1.48

Affected

introducedfixedlast affected
03.1.48-

Fixed versions

3.1.48

Sources

CVE-2026-44243 · published · modified · JSON