PyPI/tensorflow CVE-2021-29517: low 2.5, EPSS 0.19%
Division by zero in `Conv3D`
Action: Upgrade tensorflow to 2.1.4 or later.
pip install tensorflow==2.1.4pip install tensorflow==2.2.3pip install tensorflow==2.3.3pip install tensorflow==2.4.2Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 2.1.4 | - |
| 2.2.0 | 2.2.3 | - |
| 2.3.0 | 2.3.3 | - |
| 2.4.0 | 2.4.2 | - |
Fixed versions
| 2.1.4 | 2.2.3 | 2.3.3 | 2.4.2 |
Sources
- osv: GHSA-772p-x54p-hjrv
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-772p-x54p-hjrv
- https://nvd.nist.gov/vuln/detail/CVE-2021-29517
- https://github.com/tensorflow/tensorflow/commit/799f835a3dfa00a4d852defa29b15841eea9d64f
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2021-445.yaml
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2021-643.yaml
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2021-154.yaml
CVE-2021-29517 · published · modified · JSON