PyPI/gitpython CVE-2026-78675: high 8.4, EPSS 0.18%
GitPython: Arbitrary local file content disclosure via [include] directive in untrusted .gitmodules (SubmoduleConfigParser never disables merge_includes)
Action: Upgrade gitpython to 3.1.59 or later.
pip install gitpython==3.1.59Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 3.1.59 | - |
Fixed versions
| 3.1.59 |
Sources
- osv: GHSA-7833-fr7j-v32q
- https://github.com/gitpython-developers/GitPython/security/advisories/GHSA-7833-fr7j-v32q
- https://nvd.nist.gov/vuln/detail/CVE-2026-78675
- https://github.com/gitpython-developers/GitPython/pull/2211
- https://github.com/gitpython-developers/GitPython/commit/ef7568e3b317ce617eacda39b8b54dcdff8c3b5c
- https://github.com/gitpython-developers/GitPython
- https://github.com/gitpython-developers/GitPython/releases/tag/3.1.59
- https://github.com/pypa/advisory-database/tree/main/vulns/gitpython/PYSEC-2026-3785.yaml
- https://www.vulncheck.com/advisories/gitpython-before-local-file-content-disclosure-via-gitmodules
CVE-2026-78675 · published · modified · JSON