PyPI/tensorflow-gpu CVE-2021-41204: medium 5.5, EPSS 0.14%
Segfault while copying constant resource tensor
Action: Upgrade tensorflow-gpu to 2.4.4 or later.
pip install tensorflow-gpu==2.6.1pip install tensorflow-gpu==2.5.2pip install tensorflow-gpu==2.4.4Affected
| introduced | fixed | last affected |
|---|---|---|
| 2.6.0 | 2.6.1 | - |
| 2.5.0 | 2.5.2 | - |
| 0 | 2.4.4 | - |
Fixed versions
| 2.6.1 | 2.5.2 | 2.4.4 |
Sources
- osv: GHSA-786j-5qwq-r36x#PyPI/tensorflow-gpu
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-786j-5qwq-r36x
- https://nvd.nist.gov/vuln/detail/CVE-2021-41204
- https://github.com/tensorflow/tensorflow/commit/7731e8dfbe4a56773be5dc94d631611211156659
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2021-614.yaml
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2021-812.yaml
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2021-397.yaml
- https://github.com/tensorflow/tensorflow
CVE-2021-41204 · published · modified · JSON