PyPI/python-keystoneclient CVE-2014-7144: medium 5.9, EPSS 1.90%
OpenStack keystonemiddleware does not verify certificate
Action: Upgrade python-keystoneclient to 0.11.0 or later.
pip install python-keystoneclient==0.11.0pip install python-keystoneclient==1.2.0Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 0.11.0 | - |
| 1.0 | 1.2.0 | - |
Fixed versions
| 0.11.0 | 1.2.0 |
Sources
- osv: GHSA-7f2c-vp52-gmfw#PyPI/python-keystoneclient
- https://nvd.nist.gov/vuln/detail/CVE-2014-7144
- https://bugs.launchpad.net/python-keystoneclient/+bug/1353315
- https://github.com/openstack/ossa/blob/23e15de721f4a6890374a231d93524e02965a97f/ossa/OSSA-2014-030.yaml
- https://github.com/pypa/advisory-database/tree/main/vulns/keystonemiddleware/PYSEC-2014-26.yaml
- https://github.com/pypa/advisory-database/tree/main/vulns/python-keystoneclient/PYSEC-2014-71.yaml
- https://web.archive.org/web/20200228053850/http://www.securityfocus.com/bid/69864
- https://web.archive.org/web/20200228060511/https://www.securityfocus.com/bid/69864
- http://rhn.redhat.com/errata/RHSA-2014-1783.html
- http://rhn.redhat.com/errata/RHSA-2014-1784.html
- http://rhn.redhat.com/errata/RHSA-2015-0020.html
- http://www.openwall.com/lists/oss-security/2014/09/25/51
- http://www.ubuntu.com/usn/USN-2705-1
CVE-2014-7144 · published · modified · JSON