PyPI/ipa CVE-2019-14867: high 8.8, EPSS 7.41%
Code injection in FreeIPA
Action: Upgrade ipa to 4.6.7 or later.
pip install ipa==4.6.7pip install ipa==4.7.4pip install ipa==4.8.3Affected
| introduced | fixed | last affected |
|---|---|---|
| 4.6.2 | 4.6.7 | - |
| 4.7.0 | 4.7.4 | - |
| 4.8.0 | 4.8.3 | - |
Fixed versions
| 4.6.7 | 4.7.4 | 4.8.3 |
Sources
- osv: GHSA-7hpj-hfcr-5qwm
- https://nvd.nist.gov/vuln/detail/CVE-2019-14867
- https://access.redhat.com/errata/RHBA-2019:4268
- https://access.redhat.com/errata/RHSA-2020:0378
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-14867
- https://github.com/advisories/GHSA-7hpj-hfcr-5qwm
- https://github.com/pypa/advisory-database/tree/main/vulns/ipa/PYSEC-2019-28.yaml
- https://github.com/pypa/advisory-db/tree/main/vulns/ipa/PYSEC-2019-28.yaml
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/67SEUWJAJ5RMH5K4Q6TS2I7HIMXUGNKF
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/WLFL5XDCJ3WT6JCLCQVKHZBLHGW7PW4T
- https://www.freeipa.org/page/Releases/4.6.7
- https://www.freeipa.org/page/Releases/4.7.4
- https://www.freeipa.org/page/Releases/4.8.3
CVE-2019-14867 · published · modified · JSON