tocsin

PyPI/nanopb CVE-2021-21401: high 7.1, EPSS 1.81%

nanopb vulnerable to invalid free() call with oneofs and PB_ENABLE_MALLOC

Action: Upgrade nanopb to 0.3.9.8 or later.

pip install nanopb==0.3.9.8
pip install nanopb==0.4.5

Affected

introducedfixedlast affected
0.3.20.3.9.8-
0.4.00.4.5-

Fixed versions

0.3.9.80.4.5

Sources

CVE-2021-21401 · published · modified · JSON