PyPI/vllm CVE-2026-44223: medium 6.5, EPSS 0.37%
vLLM: extract_hidden_states speculative decoding crashes server on any request with penalty parameters
Action: Upgrade vllm to 0.20.0 or later.
pip install vllm==0.20.0Affected
| introduced | fixed | last affected |
|---|---|---|
| 0.18.0 | 0.20.0 | - |
Fixed versions
| 0.20.0 |
Sources
- osv: GHSA-83vm-p52w-f9pw
- https://github.com/vllm-project/vllm/security/advisories/GHSA-83vm-p52w-f9pw
- https://nvd.nist.gov/vuln/detail/CVE-2026-44223
- https://github.com/vllm-project/vllm/pull/38610
- https://github.com/pypa/advisory-database/tree/main/vulns/vllm/PYSEC-2026-145.yaml
- https://github.com/vllm-project/vllm
CVE-2026-44223 · published · modified · JSON