PyPI/h2 CVE-2025-57804: medium 6.9, EPSS 1.80%
h2 allows HTTP Request Smuggling due to illegal characters in headers
Action: Upgrade h2 to 4.3.0 or later.
pip install h2==4.3.0Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 4.3.0 | - |
Fixed versions
| 4.3.0 |
Sources
- osv: GHSA-847f-9342-265h
- nvd: CVE-2025-57804
- https://github.com/python-hyper/h2/security/advisories/GHSA-847f-9342-265h
- https://github.com/python-hyper/h2/commit/035e9899f95e3709af098f578bfc3cd302298e3a
- https://github.com/python-hyper/h2
- https://lists.debian.org/debian-lts-announce/2025/09/msg00004.html
CVE-2025-57804 · published · modified · JSON