PyPI/bottle CVE-2014-3137: critical 9.8, EPSS 3.13%
Bottle does not properly limit content-types
Action: Upgrade bottle to 0.10.12 or later.
pip install bottle==0.10.12pip install bottle==0.11.7pip install bottle==0.12.6Affected
| introduced | fixed | last affected |
|---|---|---|
| 0.10.0 | 0.10.12 | - |
| 0.11.0 | 0.11.7 | - |
| 0.12.0 | 0.12.6 | - |
Fixed versions
| 0.10.12 | 0.11.7 | 0.12.6 |
Sources
- osv: GHSA-873q-wpqr-xfgw
- https://nvd.nist.gov/vuln/detail/CVE-2014-3137
- https://github.com/bottlepy/bottle/issues/616
- https://github.com/defnull/bottle/issues/616
- https://bugzilla.redhat.com/show_bug.cgi?id=1093255
- https://github.com/bottlepy/bottle
- https://github.com/pypa/advisory-database/tree/main/vulns/bottle/PYSEC-2014-77.yaml
- http://www.debian.org/security/2014/dsa-2948
- http://www.openwall.com/lists/oss-security/2014/05/01/15
CVE-2014-3137 · published · modified · JSON