PyPI/keystonemiddleware CVE-2015-7546: high 7.5, EPSS 2.00%
OpenStack Identity Keystone and keystonemiddleware Insufficiently Protected Credentials
Action: Upgrade keystonemiddleware to 1.5.4 or later.
pip install keystonemiddleware==4.1.0pip install keystonemiddleware==1.5.4pip install keystonemiddleware==2.3.3Affected
| introduced | fixed | last affected |
|---|---|---|
| 2.4.0 | 4.1.0 | - |
| 0 | 1.5.4 | - |
| 1.6.0 | 2.3.3 | - |
Fixed versions
| 4.1.0 | 1.5.4 | 2.3.3 |
Sources
- osv: GHSA-8c4w-v65p-jvcv#PyPI/keystonemiddleware
- https://nvd.nist.gov/vuln/detail/CVE-2015-7546
- https://github.com/openstack/keystone/commit/bff03b5726fe5cac93d44a66715eea49b89c8cb0
- https://github.com/openstack/keystone/commit/d5378f173da14a34ca010271477337879002d6d0
- https://github.com/openstack/keystonemiddleware/commit/96ab58e6863c92575ada57615b19652e502adfd8
- https://bugs.launchpad.net/keystone/+bug/1490804
- https://github.com/pypa/advisory-database/tree/main/vulns/keystonemiddleware/PYSEC-2016-20.yaml
- https://security.openstack.org/ossa/OSSA-2016-005.html
- https://web.archive.org/web/20200228002640/http://www.securityfocus.com/bid/80498
- https://wiki.openstack.org/wiki/OSSN/OSSN-0062
- http://www.oracle.com/technetwork/topics/security/bulletinapr2016-2952098.html
CVE-2015-7546 · published · modified · JSON