tocsin

PyPI/sanic CVE-2022-35920: high 8.3, EPSS 1.20%

sanic vulnerable to Path Traversal when using `app.static` if using encoded `%2F` URLs

Action: Upgrade sanic to 20.12.7 or later.

pip install sanic==22.6.1
pip install sanic==21.12.2
pip install sanic==20.12.7

Affected

introducedfixedlast affected
22.0.022.6.1-
21.0.021.12.2-
020.12.7-

Fixed versions

22.6.121.12.220.12.7

Sources

CVE-2022-35920 · published · modified · JSON