PyPI/praisonai CVE-2026-40114: high 7.2, EPSS 0.24%
PraisonAI Vulnerable to Server-Side Request Forgery via Unvalidated webhook_url in Jobs API
Action: Upgrade praisonai to 4.5.128 or later.
pip install praisonai==4.5.128Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 4.5.128 | - |
Fixed versions
| 4.5.128 |
Sources
- osv: GHSA-8frj-8q3m-xhgm
- https://github.com/MervinPraison/PraisonAI/security/advisories/GHSA-8frj-8q3m-xhgm
- https://nvd.nist.gov/vuln/detail/CVE-2026-40114
- https://github.com/MervinPraison/PraisonAI
- https://github.com/MervinPraison/PraisonAI/releases/tag/v4.5.128
CVE-2026-40114 · published · modified · JSON